WordPress 升级 PHP 版本到7.2及遇到的数据库链接问题。

2020-11-28 947点热度 1人点赞 0条评论

一直想升级一下PHP版本,不知道如何升级,也没有时间去管理。然而想把网站主题改变一下。谁知道。好多要升级到PHP7.0以上版本。看了看。站点上面最高设置到PHP7.2

现在是PHP5.6,设置7.0就出错误。

为什么要升级到7.0以上

相较于PHP 5.3而言,7.0运行环境下的WordPress的处理能力是前者的3倍强。

您的网站将更加安全。

更快的WordPress网站将受到搜索引擎的奖励,因此您在搜索中的排名会更高!
速度更快的网站可以更好地吸引访问者(如果加载时间太长,他们会离开),从而使您的网站更有效。
一个更安全的网站可以更好地保护免受黑客攻击,以及与被黑客入侵的网站相关的成本和声誉损失。

升级前准备

1.先把wordpress升级到最新版本。现在是5.5.3。

2.备份网站。

如果出现任何问题,备份将使您将网站恢复为现在的状态。有很多免费的备份插件可用,因此,如果您还没有备份解决方案,请使用其中之一。为了还原此备份,您还需要Web主机将PHP版本移回当前版本(稍后将介绍如何执行此操作)。

3.更新WordPress,主题和插件:从WordPress仪表板,转到Updates,然后全部更新。无论如何,您应该定期执行此操作。🙂完成后,检查您的网站是否按预期工作。

4.检查PHP兼容性:安装PHP兼容性检查器插件以检查主题和插件是否存在问题。该插件不是完美的,可能会丢失项目或标记误报,但在大多数情况下确实可以使用。

  •     在WordPress中,导航至Plugins> Add New 。
  •     搜索“PHP Compatibility Checker plugin"   PHP兼容性检查器。
  •     出现插件后,选择立即安装>激活 。
  •    在WordPress的左侧菜单中,导航至工具> PHP Compatibility Checker plugin。
  •     选择您计划升级到的PHP版本,通常是最新版本。

    在以下选项之间选择: Only scan acti....仅扫描活动的插件和主题或扫描所有插件和主题 。
    单击 Scansite again  “ 扫描站点”按钮。

这个扫描过程很慢,等了本个小时还没完成。可以干点别的事。扫描后应该出现的结果如下:

绿色代表兼容,黄色表示该插件更新后可兼容,红色表示不兼容,灰色表示无法读取。

我采取的办法。不兼容的办法就直接禁用。不知道兼容不兼容。也禁用为好。

完成这些步骤,您就可以准备在WordPress网站上更新PHP版本了,并享受由此带来的所有好处!

我们用的阿里去服务器。

https://cp.aliyun.com/login

登录后台。

高级环境设置---》PHP版本设置

保存设置后。打开网站看看有没有问题。

出现错误了。

Wordpress升级PHP7.0后出现,错误信息是:Error establishing a database connection

这是网站后台登录后刷新出错的

这是网站前吧出现的信息。

数据库链接出错。怎么解决呢。找了半天。

只是切换了一下PHP版本就出现这个错误。

其实。在切换的时候有提示:

PHP版本设置为5.3及以上,需在重置数据库密码时,将数据库加密模式设置为41位加密!

忘记重置一下,数据库密码。

修改完成后,问题解决了。

xiaoyao

这个人很懒,什么都没留下

文章评论